le forum de MineStrator

Nous ne cherchons pas à être un forum, mais le forum de référence pour les administrateurs et joueurs de serveurs minecraft, la communauté a besoin de toi, alors n'hésite pas à t'inscrire et à participer à la vie du forum !

AntiPlugins / WorldEdit Protection (1.8/1.9/1.10/1.11/1.12)

#1
AntiPlugins

Vous souhaitez que vos joueurs ne voient plus vos plug-ins ? Vos joueurs font crash votre serveur à cause de WorldEdit ? Alors ce skript est fait pour vous !

Features:


  • Les messages sont configurables à 100%
  • Le skript contient une config pour configurer les messages facilement.
  • L'option WorldEdit protection peut être activée et désactivée depuis la config, par défaut l'option WorldEdit protection est désactivé. Vous devez l'activer depuis la config en mettant "true" pour activer ou "false" pour désactiver.
Le Skript permet donc de ne pas voir vos plug-ins minecraft, voici donc les commandes bloquées:

  • /pl
  • /plugins
  • /plugin
  • /bukkit:help
  • /bukkit: pl
  • /bukkit: plugins
  • /bukkit:?
  • /help
  • /?
  • /ver
  • /version
  • /bukkit:ver
  • /bukkit:version
  • /about
  • /bukkit:about
  • /icanhasbukkit
  • /bukkit:me
  • /minecraft:me
  • /ver <tab>
  • /version <tab>
  • /about <tab>
  • /bukkit:about <tab>
  • /? <tab>

  • //calc (WorldEdit protection)
  • //calculate (WorldEdit protection)
  • //eval (WorldEdit protection)
  • //evaluate (WorldEdit protection)
  • //solve (WorldEdit protection)
  • /worldedit:/calc (WorldEdit protection)
  • /worldedit:/calculate (WorldEdit protection)
  • /worldedit:/solve (WorldEdit protection)
  • /worldedit:/eval (WorldEdit protection)
  • /worldedit:/evaluate (WorldEdit protection)

  • Multiples langages (FR/EN/ES/GER/IT)
  • Fonctionne en 1.8 - 1.9 - 1.10 - 1.11 - 1.12 (si vous souhaitez la version 1.7, merci de prendre AntiPluginsV3.4)
Commandes:


  • /antipl | Affiche la page d'aide
  • /antipl reload | Permet de reload le skript
  • /antipl <fr/en/ger/es/it/> | Permet de définir la langue du Skript.
Addons


  • Skript 2.2
  • SkRayFall
  • WildSkript
  • SkQuery
Installation:


  1. Déposez dans votre dossier "Skript" le Skript AntiPlugins.sk dans le dossier Skript/script/
  2. Ensuite, merci de faire /sk reload all sur votre serveur
  3. Le skript est maintenant installé !
Permissions


  • plugins.use (Cette permission permet à un utilisateur non opérateur de voir vos plugins.)
Téléchargement


Merci de signaler les bugs / fautes , une mise à jour sera rapidement disponible pour corriger les problèmes que vous rencontrez !
Je vous remercie d'utiliser AntiPluginsV4 !
 

D0fy

Membre
#5
Ce skript date, je l'avais déjà vu sur skript-mc V1 ^^ Sinon il a l'air très propre : D
 
#7
Je ne vois pas à quoi ça sert d'avoir WildSkript dans ses addons 🤔

Et petite suggestion : Rajouter le bloquage de la commande "/pex promote" pour les serveurs utilisant (encore) PermissionsEx
Cette commande, mal exécutée va afficher toutes les possibilités d'utiliser /pex promote avec tous les joueurs ayant été sur le serveur, si le serveur a accueilli plusieurs milliers de joueurs, il plantera à l'exécution de la commande
 

D0fy

Membre
#8
Je ne vois pas à quoi ça sert d'avoir WildSkript dans ses addons 🤔

Et petite suggestion : Rajouter le bloquage de la commande "/pex promote" pour les serveurs utilisant (encore) PermissionsEx
Cette commande, mal exécutée va afficher toutes les possibilités d'utiliser /pex promote avec tous les joueurs ayant été sur le serveur, si le serveur a accueilli plusieurs milliers de joueurs, il plantera à l'exécution de la commande

Comment ça utilisant "encore" permissionex il est très bien ce plugin : |
 
#9
Il est abandonnée depuis 2016, l'auteur est au courant pour ce bug, il a donc ... Retiré la section "Issue" du GitHub voilà 😐
 
Auteur
Auteur
Acenox

Acenox

Membre
#10
Ce skript date, je l'avais déjà vu sur skript-mc V1 ^^ Sinon il a l'air très propre : D
Oui il date en effet x) C'est un de mes seuls skript en ligne, un jour je posterai mes skripts personnels x)
il a été mis à jour il n'y a pas longtemps si je ne dit pas de bêtise
Wep, je le met à jour de temps en temps (la dernière maj date de juin)
Je ne vois pas à quoi ça sert d'avoir WildSkript dans ses addons 🤔

Et petite suggestion : Rajouter le bloquage de la commande "/pex promote" pour les serveurs utilisant (encore) PermissionsEx
Cette commande, mal exécutée va afficher toutes les possibilités d'utiliser /pex promote avec tous les joueurs ayant été sur le serveur, si le serveur a accueilli plusieurs milliers de joueurs, il plantera à l'exécution de la commande
WildSkript, sert simplement à faire les fichiers de configuration, car je suis encore dans l'époque "old school" a ne pas encore utiliser SkUtilities x) mais quand j'aurai le temps, je passerai sur SkUtilities pour remplacer WildSkript. sinon, je prends en compte pour permission ex ;) ça peut toujours servir.
Comment ça utilisant "encore" permissionex il est très bien ce plugin : |
Personnellement je n'ai jamais aimé PermissionEX, je préfère largement PowerFullPerm ^^'
 

Haut